アドセンス自動広告が表示されない場合の対処方法

この記事をご覧の皆様はすでにGoogleアドセンスの自動広告を設定しているにもかかわらず表示されないことが問題となっていると思います。

この記事は次の課題に対処します。

■自動広告の設定をしたのに表示されない
■原因を知りたい
■どうすればよいか対処方法を知りたい

2週間に渡り様々な試行錯誤しながら、その実験から得たデータを基に改善したので報告します。

ネット上の記事で紹介されてる対処方法は、(1)コードの確認、(2)自動広告の設定がされているか(3)プライバシーポリシー違反は無いか等ですね。

設定は間違いなくされている! しかし・・

確認しても、設定はなされている場合で自動広告が表示されない。いったい原因は何か?

自動広告設定のあとに、何か変更しなかった?

自分の場合は、ここが大きなポイントです。

最初に疑ったのは以下の「変更内容が原因ではないか」です。

自動広告を設定したのにもかかわらず、さらにプラグインを入れて、マニュアルで広告コードを追加して入れた。

理由は、自動広告にプラスしてさらに露出効果を上げるべく追加設定したのです。

具体的に何をしたか

プラグイン「WP QUADS」をインストールした。

このプラグインを使って、記事下に「リンクユニット広告」を出す設定をした。

こんな広告です。 

どうなったか?

気が付くと自動広告が表示されてはいるのですが、だんだん表示回数が少なくなり、とうとう表示されなくなってしまった。

その後、後から追加したこのリンクユニット広告しか表示されなくなった。

自動広告が完全に消えてしまった・・・真っ青になる。

そこで、冷静に反省をする。

対処方法

(1)自動広告を再度設定する。

Googleアドセンスの管理画面から、自動広告の各項目設定を再度On-Offをして設定を保存する。要は、一回リセットして設定する感じです。

「再設定したぞ!」とGoogleアドセンスに訴えたのです・・・

(2)「リンクユニット広告」を中止する。

プラグインからリンクユニット広告を止める。「WP QUADS」の設定をOFFにする。写真のチェックしたところのチェックをはずして保存する。

その結果、表示されるようになった。

その結果、5分後位から自動広告がいろいろな所に元気に表示されるようになりました。一安心です。

さらに5分後には、クリックが1件入りました。自動広告が正常になった結果とおもわれます。

原因はなにか?

わかりません。

推測した仮説に基づいてやってみたら、表示が戻ったという事です。根拠を説明することはできませんが、結果として正常に動いています。

仮説は以下の通りです。

自動広告はGoogleアドセンスが開発したシステムです。なので広告表示はこれだけで十分としている。

そこに、欲を出してさらに追加で「リンクユニット広告」を入れたので、単純に自動広告がストップしたのではないか。「それは出しすぎだから、自動広告を止めるよ!」という感じ。

まとめ

この2週間は、正直青くなりました。今回は関連記事にあるような減少が発生したので、それを仮説をたてて実験したのです。

Googleアドセンスのアルゴリズムはどのように判断したのかはブラックボックスです。

そのブラックボックスをつついてみたら、結果が変わったのです。オブジェクト指向のクラスみたいですね・・・

自分は、プラグインで自動広告にさらに広告を追加設定したためと思われます。

関連記事>>>こちら

tabito(旅人)

追記 その後の状況について

追記:2019年3月28日

原因が分からないけど、現象としては上記の様になりました。そこで、確認のため、日を変えて再度実験してみました。

プラグイン 「WP QUADS」 から、リンクユニット広告を一番上と最後に交互に入れて試験してみました。

結果、リンクユニット広告を入れると、テーマのキャッチ画像の上下に出ていた自動広告が片方表示になります。また、サイドバーに出ていた広告も消えてしまいます。記事中に3つ表示されていた広告は、ゼロか1位です。記事下に出ていた広告も無くなりました。

リンクユニット広告を止める。

すると、3~5個の自動広告が表示されるようになりました。

リンクユニット広告は効果が期待できるのですが、現状の自動広告で毎日収益が出ているので当分このままで進めて行きます。

後日、あらためて3度目のテストを1週間実施して収益が変わるかどうかを確認したいと思います。

tabito(旅人)

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です